Install

ATcl is an integrator library, and therefore Tcl itself is primarily necessary. Tcl is freely available and has no licensing encumbrances (usually the license BSD-like).

To work with MT4, you will need 32-bit (this is important! MT4 32-bit, but 64-bit libraries will not work with it) version of Tcl. You can use any of the Tcl distributions:

You can even compile yourself :-)

the distribution includes useful demonstrations

Unpack the contents of the archive into the data directory of your terminal.

The archive contains the following files:

  • MQL4 / Libraries / ATcl / atcl.dll - DLL library. Component required for installation
  • MQL4 / Include / ATcl / atcl.mqh - MQL library interface. Contains class ATcl
  • MQL4 / Files / ATcl / - contains tcl demo files. At least the directory must be created
  • MQL4 / Experts / ATcl / - contains demonstration experts. It`s optional.
  • MQL4 / Indicators / ATcl / - demo indicator. Also optional
  • MQL4 / Scripts / ATcl - demo scripts. Optional

Everything is ready to go!